Doorzoek het forum

Trefwoord

Welkom bij Joomla!NL

Om alle mogelijkheden van dit forum te kunnen gebruiken, moet je je eerst registreren.

× Vermeld in iedere vraag duidelijk:
1 De versie van Joomla! 1.5 die je gebruikt
2 De volledige url van je website indien mogelijk.
3 De versie van de extensie waar de vraag over gaat.

opgelost krijg na lek jce site niet terug goed

05 juni 2013 22:20
Heeft onderwerp gestart
opgelost krijg na lek jce site niet terug goed #1
Een maand geleden werd een site door de host op suspended gezet.
Ik zat blijkbaar met een oude JCE versie constateerde ik na wat zoeken op internet.

Heb toen JCE gedeïnstalleerd, maar kreeg een foutboodschap dat niet alle bestanden verwijderd werden. Component was we weg uit de lijst, maar zag nog enkele bestanden staan via bestandsbeheer. Heb er toen nog een aantal manueel verwijderd.

Verder heb ik alle mappen doorzocht naar recente datum van wijzigingen. In al deze mappen vond ik .htaccess bestanden die op het eerste zicht leeg leken, maar waar onderaan meerdere rewrite-commando's stonden.
Heb al deze bestanden gewist en dacht dat het hiermee opgelost zou zijn.

Niet dus, vandaag werd door Host de site opnieuw op suspended gezet omdat er een lek is dat gebruikt wordt om spam en pishing te tonen.
De host gaf nog de volgende info door:
Spamvertised web site: http://www.recht-op-doel.be/New/css_....145.9.1.0/wo/ 
http://www.spamcop.net/w3m?i=z595650...4f305a212fc97z 
http://www.recht-op-doel.be/New/css_....145.9.1.0/wo/ is 85.158.210.206; Sun,

Zou het lek niet weg zijn? Dien ik op zoek te gaan naar resterende JCE-bestanden, die mogelijks het lek nog instand houden. Of dien ik nog andere zaken te doen
Alvast voor het meedenken
joker
joker
Nieuw op Joomla!NL
Nieuw op Joomla!NL
Berichten: 14
Lees meer
06 juni 2013 00:27
opgelost krijg na lek jce site niet terug goed #2
Ai... Ik raad ten minste het volgende aan:

- Alle wachtwoorden veranderen, administrators, super users van Joomla. Webshosting, FTP, database ed
- Gebruikers nakijken
- Cronjob nakijken
- Scan van fix.myjoomla.com/ uitvoeren
- Database globaal nakijken
- Bestandsrechten nakijken en corrigeren
- Admin Tools Pro installeren en goed instellen
- Logs controleren en in de gaten houden
- ...

Bestanden die je niet kan verwijderen doet denken aan issue met rechten. Je hebt wellicht ook bestanden/mappen op 777 staan? Dat is onveilig (!). Als je site onder apache2handler draait dan raad ik aan om je host te vragen dit om te zetten naar SUPHP/FcGI of van host te switchen.

Een host kan zelf overigens ook gehackt zijn en dan kan je doen wat je wilt maar dan kan je het niet oplossen. Ook dient je host zelf up-to-date te zijn. Apache, FTP etc. Goedkoop = duurkoop.

Als je ergens één ding of bestandje over het hoofd ziet ben je in notime weer (of nog steeds) gehackt. Het kan ook in een van de duizenden bestaande bestanden verborgen zijn. Inderdaad, een gehackte site is ellende...

Het beste is overigens je site backuppen, volledig verwijderen en opnieuw opbouwen. Is echter ook het meeste werk. Hopelijk lukt het je beter met deze tips.
Jurian
Bekend met Joomla!NL
Bekend met Joomla!NL
Berichten: 80
Lees meer
06 juni 2013 09:04
opgelost krijg na lek jce site niet terug goed #3
Nog even als aanvulling op de geweldige uitleg van Jurian: Scan ook je eigen computer met diverse virusscanners. Een groot deel van de hacks wordt veroorzaakt door virussen/malware op de computer van de beheerder!

Groetjes, Astrid
Gebruik de zoekfunctie van dit forum voordat je een nieuwe vraag plaatst.
Vragen uitsluitend via dit Forum.
yndi.nl - kvk 17157725
Is je vraag beantwoord? Dan kan je het draadje zelf sluiten .
Wil je Joomla!NL steunen? Dat kan met een donatie.

Deze afbeelding is verborgen voor gasten.
Login of registreer om deze te zien.

Astrid
Moderator + Technisch team
Moderator + Technisch team
Berichten: 35743
Lees meer
06 juni 2013 20:37
Heeft onderwerp gestart
opgelost krijg na lek jce site niet terug goed #4
bedankt Jurian en Astrid,ik ga hier morgen mee aan de slag.
gezien de beheerder de enige gebruiker is, ligt dit eenvoudig. 'k zal hem wel moeten vragen of hij een degelijk antivirusprogramma heeft.
Wachtwoorden wijzigen voor database, admin en ftp was ik al van plan.
Bestandrechten staan zoals het hoort mappen op 755 of bestanden op 644.
De foutmelding bij het deïnstalleren van JCE had m.i. te maken met bestandrechten.
Mss dat ik de map editors integraal verwijder en een verse map upload, ben ik zeker dat alles van de component JCE weg is.
grt joker
joker
Nieuw op Joomla!NL
Nieuw op Joomla!NL
Berichten: 14
Lees meer
08 juni 2013 10:55
Heeft onderwerp gestart
opgelost krijg na lek jce site niet terug goed #5
Ondertussen bovenstaande gedaan. Heb heel de map editor uit de map plugins verwijderd en een verse map teruggeplaatst, gezien er hier en daar nog restanten van jce terug te vinden waren.
Blijkbaar werden er heel wat mails en plaatjes verstuurd. Volledig vreemde map met inhoud moeten verwijderen.
Voor plaatjes was een map gemaakt in de map stories.
Alle wachtwoorden zijn gewijzigd.
Op hoop van zege dat ze nu wegblijven.
grt
joker
joker
Nieuw op Joomla!NL
Nieuw op Joomla!NL
Berichten: 14
Lees meer
08 juni 2013 13:38
opgelost krijg na lek jce site niet terug goed #6
Het gaat niet enkel om JCE maar om alle mappen en bestanden van je website.
Jurian
Bekend met Joomla!NL
Bekend met Joomla!NL
Berichten: 80
Lees meer
08 juni 2013 13:44
Heeft onderwerp gestart
opgelost krijg na lek jce site niet terug goed #7
Dag Jurian,
Heb alle mappen systematisch doorlopen naar vreemde en/of recent gewijzigde bestanden.
Wat vreemd was verwijderd, wat recent gewijzigd was nagekeken.
Maar blijkbaar toch iets te grondig geweest.
Als ik een artikel probeer te openen, krijg ik een wit scherm, dus geen editor te zien.
Bij algemene instellingen staat de editor op tiny.
Moet ik er eens een volledig nieuwe joomla-versie opzetten met uitzondering van de map installation?
alvast bedankt
grt
jo
joker
Nieuw op Joomla!NL
Nieuw op Joomla!NL
Berichten: 14
Lees meer
08 juni 2013 13:48
opgelost krijg na lek jce site niet terug goed #8
Het beste maak je een backup, verwijder je alle bestanden en installeer je Joomla opnieuw. Waarom eerst verwijderen ipv eroverheen zetten? Dan weet je zeker dat alle besmette bestanden weg zijn.

Dan ook de extensies en template opnieuw installeren (zelfde versies als wat je had) en de database tabellen overzetten. Alle custom bestanden (template overrides ed) grondig nakijken en overzetten. Dan kijken of het werkt en dan updaten en beveiligen. Dit is echter niet voor een beginner, met name het stoeien met de database.

Als je een wit scherm krijgt kan je error_reporting op maximum zetten in je configuration.php.
Jurian
Bekend met Joomla!NL
Bekend met Joomla!NL
Berichten: 80
Lees meer
08 juni 2013 15:45
opgelost krijg na lek jce site niet terug goed #9
Hallo,
:off:
Toch even een opmerking van deze kant met oog op de toekomst om dit soort problemen te voorkomen.

Op 30 september 2012 is de ondersteuning voor Joomla 1.5 gestopt.
Er zullen geen updates / veiligheidpatches en dergelijke aanvullingen of verbeteringen meer voor worden ontwikkeld en aangeboden.
Dus is de site nu erg onveilig!
Ook de extensie-ontwikkelaars zullen vanaf die datum niet meer hun aandacht voor Joomla 1.5-extensies hebben.
Alles zal vanaf die datum zijn gericht op het huidige Joomla 2.5 en het in ontwikkeling zijnde Joomla 3.x.
Joomla 3.x is de tussenversie voor de uiteindelijke 3.5
:back:

Groeten, Jelle
Voordat je een vraag post, gebruik eerst de zoekfunctie van ons forum eens.
Vragen via dit Forum (niet per PM of E-mail)
Is je vraag opgelost? Dan kan je hem zelf sluiten .
Wil je Joomla!NL steunen? Dat kan met een donatie.

Deze afbeelding is verborgen voor gasten.
Login of registreer om deze te zien.

Jelle
Algemeen Moderator
Algemeen Moderator
Berichten: 13425
Lees meer
08 juni 2013 21:31
Heeft onderwerp gestart
opgelost krijg na lek jce site niet terug goed #10
Allen bedankt voor de hulp en raad.
Site werkt terug naar behoren. Ik weet dat ik eens zal moeten upgraden, maar voorlopig iets te weinig tijd. Is ook vrij omslachtig. Heb ondertussen een site naar 2.5 gebracht, maar dit vroeg toch veel extra's.
groet
Joker
joker
Nieuw op Joomla!NL
Nieuw op Joomla!NL
Berichten: 14
Lees meer
08 juni 2013 21:43
opgelost krijg na lek jce site niet terug goed #11
Hallo,

Fijn dat de site weer naar behoren werkt.
Dank je wel voor de terugkoppeling.

Je kunt in de toekomst zelf na het terugkoppelen de topic sluiten door op de groene "opgelost" knop te klikken.

Groeten, Jelle
Voordat je een vraag post, gebruik eerst de zoekfunctie van ons forum eens.
Vragen via dit Forum (niet per PM of E-mail)
Is je vraag opgelost? Dan kan je hem zelf sluiten .
Wil je Joomla!NL steunen? Dat kan met een donatie.

Deze afbeelding is verborgen voor gasten.
Login of registreer om deze te zien.

Jelle
Algemeen Moderator
Algemeen Moderator
Berichten: 13425
Lees meer
Moderators: Juliank92PeterJelleRomke
Tijd voor maken pagina: 0.100 seconden

Wil je Joomla!NL steunen?

Steun Joomla!NLAlle teamleden werken enthousiast, op vrijwillige basis, mee aan Joomla!NL. Maar een website met forum kost nu eenmaal geld. Dus als je Joomla!NL wilt steunen, dan kan dat, graag zelfs!

Lees hier meer informatie

Joomla!NL op Twitter

Op dinsdag 27 september 2022 is Joomla! 4.2.3 vrijgegeven. Het betreft een versie die nieuwe verbeteringen bevat en… https://t.co/T7oGdV8LSs

Joomla! 4.2.1 is vrijgegeven. Deze versie pakt een beveiligingsprobleem aan, repareert verschillende bugs en bevat… https://t.co/JHmNyhWEGq

De naam Joomla!® en logo worden gebruikt onder een beperkte licentie met toestemming van Open Source Matters.
Joomlanl.nl is niet verbonden aan en is geen onderdeel van Open Source Matters, Inc, of het Joomla! project.

© 2022 - Joomla!NL | Gehost door Wned