Joomla! 3.2.3 toont update naar 3.2.4 (Klopt dat?)

joomla 324-update 1Het updaten van een Joomla! 3.2.3-website toont voor sommigen een verwarrend statusscherm.
Want het beheerscherm in de back-end toont dat er een update beschikbaar is. En wel Joomla! 3.2.4.
Dat is raar, want waarschijnlijk had je al gecontroleerd dat de server van je provider op PHP 5.3.10 + werkt.
Moet het dan niet zo zijn dat Joomla! 3.3.0 als beschikbare update toont?
Ja en Nee.

Het zou inderdaad logisch zijn, maar blijkbaar heeft het Joomla! Project Team er niet voor gekozen.
Joomla! toont dus dat 3.2.4 beschikbaar is.
In Joomla! zit een controleprogramma ingebouwd dat controleert of de PHP-versie op de server toereikend is. Als dat niet zo is, dan zal 3.2.4 worden geactiveerd als de beschikbare update.

Maar als de provider wel netjes de PHP-versie op het juiste niveau heeft, dan voert de Joomla!-update toch een update naar 3.3.0 uit.

Het ziet er als volgt uit:

In de back-end zie je deze melding.

joomla 324-update 1

Klik op de knop "Update nu".

joomla 324-update 2

Het scherm dat dan verschijnt toont ook nog dat er een update wordt uitgevoerd naar 3.2.4.
Klik nu op de knop "Update uitvoeren".

joomla 324-update 3

Als de server op de juiste PHP-versie werkt, verschijnt toch het bericht dat je site is bijgewerkt naar de nieuwe Joomla! 3.3.0.