Doorzoek het forum

Trefwoord

Welkom bij Joomla!NL

Om alle mogelijkheden van dit forum te kunnen gebruiken, moet je je eerst registreren.

× Vermeld in iedere vraag duidelijk:
  1. De versie van Joomla! 3.X die je gebruikt
  2. De volledige url van je website indien mogelijk.
  3. De versie van de extensie waar de vraag over gaat.

opgelost Site en admin nog steeds niet beschikbaar na update naar 3.8

30 sept 2017 13:02
Heeft onderwerp gestart
opgelost Site en admin nog steeds niet beschikbaar na update naar 3.8 #1
Afgelopen week heb ik eerder een bericht geplaatst: https://forum.joomlanl.nl/forum/3-x-installatie-update-upgrade-backup-en-verhuizing/54393-site-en-admin-niet-meer-bereikbaar-na-update-naar-3-8-0 .

Uiteindelijk is gezegd dat ik mijn extensies moest updaten en het dan weer proberen. Maar ook na het updaten blijf ik dezelfde foutmeldingen krijgen. Het lukt mij dus niet om de site geupdate te krijgen naar Joomla 3.8.0.

Wat heb ik gedaan?
- Een extensie waarvan op internet niet een recente versie kon vinden verwijderd. Gebruikte ik toch niet veel.
- AdminExile heeft de juiste versie: 3.14 (na update).
- Mijn contactforumlier heeft de juiste versie. Het gaat om Creative Contact Form 4.5.0.
- Volgens mij heeft Visitors Counter van Majunke Michaei met versie 2.0.4 ook de juiste versie.
- Verder ga ik er vanuit dat de extensies van het "Joomla Project!" (de meesten) goed zijn, of dat ze door update naar versie 3.8.0 geupdate worden. Zo niet, hoe kan ik daar dan updates van vinden?

Maar...
1) Op het forum zie ik dat veel mensen ook spreken over het updaten van de template. Ik gebruik onder andere Protostar versie 1.0. Hoe vind ik daarvan of er een update beschikbaar is. Ik kan het in elk geval niet vinden. En zo is er ook nog een template voor het beheergedeelte. Zie screenprints in de bijlage bij punt 1).
2) Akeeba Backup is bij op versie 5.6.0. Maar... er zijn een hoop andere extensies die van dezelfde auteur zijn. Zijn deze ook bij? Ik kan op internet geen updates vinden.... Zie punt 2 in de bijlage.
3) Dan zijn er nog een aantal Bibliotheken en plugins waar ik geen raad mee weet. Zie punt 3 in de bijlage.

En dan als laatste: Kan het zijn dat het niet aan de extensies ligt, maar dat de zip die ik gebruik niet goed is of de manier van updaten niet goed is? De meeste updaten waarschijnlijk vanuit Joomla zelf, via de update manager. Dat lukt mij niet (hiervoor ook nooit). Dan krijg ik een foutmelding op Ajax. Daarom plaats ik de zip altijd in de root van de site, om hem daar uit te pakken. Kan het zijn dat er daardoor nu iets fout gaat? (Wat voorheen altijd wel goed ging).

Hopelijk kunnen jullie mij helpen.
AHuurnink
Nieuw op Joomla!NL
Nieuw op Joomla!NL
Berichten: 11
Meer

Dit bericht bevat een bestand als bijlage.
Log in of registreer om die te bekijken

30 sept 2017 13:51
opgelost Site en admin nog steeds niet beschikbaar na update naar 3.8 #2
Hoi,

Activeer in de configuration.php de foutrapportage eens.
(Bestand downloaden, aanpassen en uploaden)

Als je foutmeldingen ziet, zijn problemen vaak eenvoudiger op te lossen.
Aan de hand van de foutmeldingen weet je beter waar je moet zoeken.

Artenweb.nl creatieve unieke Joomla websites die werken!
KvK: 61932647 - Responsive templates, zoekmachine optimalisatie, maatwerk extensies.
Otto
Voelt zich thuis op Joomla!NL
Voelt zich thuis op Joomla!NL
Berichten: 2222
Meer
30 sept 2017 14:36 30 sept 2017 14:40 door Jelle.
Heeft onderwerp gestart
opgelost Site en admin nog steeds niet beschikbaar na update naar 3.8 #3
Ik heb opnieuw de update uitgevoerd.
Daarna in configuration.php de error_reporting ingesteld op:

$error_reporting = '6143';


Bij het benaderen van de site krijg ik weer de error 500 Applcation Instantiation error. Maar nu ook de volgende meldingen:

Notice: Constant JROUTER_MODE_RAW already defined in /var/www/vhosts/bijbelengeloof.com/httpdocs/libraries/cms/router/router.php on line 17
Notice: Constant JROUTER_MODE_SEF already defined in /var/www/vhosts/bijbelengeloof.com/httpdocs/libraries/cms/router/router.php on line 24
Notice: Constant _QQ_ already defined in /var/www/vhosts/bijbelengeloof.com/httpdocs/libraries/src/Language/Language.php on line 18


Bij het benaderen van de Administrator krijg ik weer het blauwe scherm, maar nu met de melding:

Notice: Constant _QQ_ already defined in /var/www/vhosts/bijbelengeloof.com/httpdocs/libraries/src/Language/Language.php on line 18


Wat kan ik met deze meldingen?

Edit Jelle: Ik heb de meldingen tussen tags geplaatst, volgende keer graag zelf doen.
AHuurnink
Nieuw op Joomla!NL
Nieuw op Joomla!NL
Berichten: 11
Meer
30 sept 2017 15:06
opgelost Site en admin nog steeds niet beschikbaar na update naar 3.8 #4
Hallo,

Ik zag jou probleem ook al voorbij komen bij joomla.org.
Misschien heb je er wat aan.
forum.joomla.org/viewtopic.php?f=710&t=954839&start=30

Groeten, Jelle
Voordat je een vraag post, gebruik eerst de zoekfunctie van ons forum eens.
Vragen via dit Forum (niet per PM of E-mail)
Is je vraag opgelost? Dan kan je hem zelf sluiten .
Wil je Joomla!NL steunen? Dat kan met een donatie.

Deze afbeelding is verborgen voor gasten.
Login of registreer om deze te zien.

Jelle
Algemeen Moderator
Algemeen Moderator
Berichten: 13050
Meer
30 sept 2017 15:30
Heeft onderwerp gestart
opgelost Site en admin nog steeds niet beschikbaar na update naar 3.8 #5
Bedankt voor je reactie, maar die link geeft een heleboel discussie over de problemen met 3.8.0.
Inderdaad dezelfde meldingen, maar ik zie geen oplossing beschreven (of ik moet er overheen lezen...).
Een backup kan ik ondertussen terugplaatsen, maar dan zit ik weer in 3.7.5 en ik wil naar 3.8.0.
Dus hoe kom ik op 3.8.0 of hoe kan ik de opgetreden fouten verhelpen?
AHuurnink
Nieuw op Joomla!NL
Nieuw op Joomla!NL
Berichten: 11
Meer
30 sept 2017 16:30 30 sept 2017 16:45 door AHuurnink.
Heeft onderwerp gestart
opgelost Site en admin nog steeds niet beschikbaar na update naar 3.8 #6

AHuurnink schreef : Ik heb opnieuw de update uitgevoerd.
Daarna in configuration.php de error_reporting ingesteld op:

$error_reporting = '6143';


Bij het benaderen van de site krijg ik weer de error 500 Applcation Instantiation error. Maar nu ook de volgende meldingen:

Notice: Constant JROUTER_MODE_RAW already defined in /var/www/vhosts/bijbelengeloof.com/httpdocs/libraries/cms/router/router.php on line 17
Notice: Constant JROUTER_MODE_SEF already defined in /var/www/vhosts/bijbelengeloof.com/httpdocs/libraries/cms/router/router.php on line 24
Notice: Constant _QQ_ already defined in /var/www/vhosts/bijbelengeloof.com/httpdocs/libraries/src/Language/Language.php on line 18


Bij het benaderen van de Administrator krijg ik weer het blauwe scherm, maar nu met de melding:

Notice: Constant _QQ_ already defined in /var/www/vhosts/bijbelengeloof.com/httpdocs/libraries/src/Language/Language.php on line 18


Wat kan ik met deze meldingen?

Edit Jelle: Ik heb de meldingen tussen tags geplaatst, volgende keer graag zelf doen.


Even een opmerking als aanvulling:
Ik heb ontdekt, na de backup weer terug te zetten, dat het bestand language.php onder versie 3.7.5 op een andere plek staat. De map "src" onder libraries bestaat in 3.7.5 namelijk niet. in 3.7.5 staat dit bestand in:

.../libraries/joomla/language/language.php.

Misschien (alleen dat kan ik na de restore natuurlijk niet meer zien) dat in de nieuwe situatie het bestand op beide plaatsen staat. Kan dat het conflict veroorzaken?
Daarnaast heb ik ontdekt dat het bestand router.php onder 3.7.5 op exact dezelfde locatie staat, maar op https://github.com/joomla/joomla-cms/issues/18005 heb ik de volgende opmerking gezien:



Wanneer ik in de zip van de update kijk dan zou dit bestand echter moeten staan onder

../libraries/src/Router

Ik weet nog niet zo goed wat ik hier mee moet. Bestanden wissen op de aangegeven plaatsen (zoals in de foutmeldingen aangegeven) na de update?
Zouden jullie dat doen?
Als dit de oplossing is, dan gaat er dus wat fout met het installeren door het uitpakken van de zip in de root map van de site (zie mijn eerste bericht). Want met uitpakken worden er (denk ik) natuurlijk geen bestanden verwijderd. Alhoewel deze methode tot zover altijd gewerkt heeft (ook door Joomla zelf aangeraden... voor het geval de update manager niet werkt).

Mvg
Arjan
AHuurnink
Nieuw op Joomla!NL
Nieuw op Joomla!NL
Berichten: 11
Meer

Dit bericht bevat een afbeelding als bijlage.
Log in of registreer om die te bekijken

30 sept 2017 21:55
opgelost Site en admin nog steeds niet beschikbaar na update naar 3.8 #7
Ik begrijp niet precies hoe je je update doet. Maar als de automatische update via de component niet werkt dan is het enige alternatief om het zip-bestand via de update component te installeren.

Groetjes, Astrid
Gebruik de zoekfunctie van dit forum voordat je een nieuwe vraag plaatst.
Vragen uitsluitend via dit Forum.
yndi.nl - kvk 17157725
Is je vraag beantwoord? Dan kan je het draadje zelf sluiten .
Wil je Joomla!NL steunen? Dat kan met een donatie.

Deze afbeelding is verborgen voor gasten.
Login of registreer om deze te zien.

Astrid
Moderator + Technisch team
Moderator + Technisch team
Berichten: 32898
Meer
30 sept 2017 22:33
Heeft onderwerp gestart
opgelost Site en admin nog steeds niet beschikbaar na update naar 3.8 #8
Maar dan krijg ik de volgende foutmelding:

AHuurnink
Nieuw op Joomla!NL
Nieuw op Joomla!NL
Berichten: 11
Meer

Dit bericht bevat een afbeelding als bijlage.
Log in of registreer om die te bekijken

30 sept 2017 22:46
opgelost Site en admin nog steeds niet beschikbaar na update naar 3.8 #9
Dan is er waarschijnlijk een probleem met de server configuratie en/of firewall. Dat geeft een conflict met
/administrator/components/com_joomlaupdate/restore.php

Groetjes, Astrid
Gebruik de zoekfunctie van dit forum voordat je een nieuwe vraag plaatst.
Vragen uitsluitend via dit Forum.
yndi.nl - kvk 17157725
Is je vraag beantwoord? Dan kan je het draadje zelf sluiten .
Wil je Joomla!NL steunen? Dat kan met een donatie.

Deze afbeelding is verborgen voor gasten.
Login of registreer om deze te zien.

Astrid
Moderator + Technisch team
Moderator + Technisch team
Berichten: 32898
Meer
30 sept 2017 23:57
Heeft onderwerp gestart
opgelost Site en admin nog steeds niet beschikbaar na update naar 3.8 #10
Ik ben erachter wat het probleem is.
Doordat ik wilde uitleggen welke update methode ik altijd gebruik (de handmatige procedure), en ben gaan zoeken op internet, ben ik erachter gekomen dat ik eigenlijk altijd een deel oversloeg.
Het gaat om de handmatige procedure zoals beschreven in:

https://docs.joomla.org/Updating_Joomla_(Manual_Method) .

Het deel dat ik oversloeg was hetgeen beschreven staat onder "Delete removed files".
Doordat je de zip handmatig uitpakt, worden er alleen bestanden weggeschreven die toegevoegd worden.
Er worden geen bestanden verwijderd. Blijkbaar horen er bij de update nog weleens bestanden verwijderd te worden. Wanneer je dat bij de handmatige procedure niet doet geeft dat klaarblijkelijk een conflict.
Ik heb nu die extra stap ook uitgevoerd en de site is up en running onder 3.8.0!

Bedankt voor het meedenken want dat heeft zeker geholpen om de juiste gegevens te vinden!
AHuurnink
Nieuw op Joomla!NL
Nieuw op Joomla!NL
Berichten: 11
Meer
Moderators: PeterJuliank92JelleRomke
Tijd voor maken pagina: 0.352 seconden

Wil je Joomla!NL steunen?

Steun Joomla!NLAlle teamleden werken enthousiast, op vrijwillige basis, mee aan Joomla!NL. Maar een website met forum kost nu eenmaal geld. Dus als je Joomla!NL wilt steunen, dan kan dat, graag zelfs!

Lees hier meer informatie

Joomla!NL op Twitter

Joomla! 3.9.8 is vrijgegeven. In 3.9.7 ging het verwijderen van de niet-officiële Franse Help-server niet goed. Dat… https://t.co/zT2e29bm4S

Joomla! 3.9.7 is dinsdag 11 juni vrijgegeven. Deze versie bevat enkele veiligheidsoplossingen en enkele bugreparati… https://t.co/pHuxvXM8Ek

De naam Joomla!® en logo worden gebruikt onder een beperkte licentie met toestemming van Open Source Matters.
Joomlanl.nl is niet verbonden aan en is geen onderdeel van Open Source Matters, Inc, of het Joomla! project.

© 2019 - Joomla!NL | Gehost door Wned