Welkom bij Joomla!NL

Om alle mogelijkheden van dit forum te kunnen gebruiken, moet je je eerst registreren.

Vermeld in iedere vraag duidelijk:
  1. De versie van Joomla! 4.X die je gebruikt
  2. De volledige url van je website indien mogelijk.
  3. De versie van de extensie waar de vraag over gaat.

Wachtwoord ‘reset’ en gebruikersnaam ‘remind’ links werken niet

Wachtwoord ‘reset’ en gebruikersnaam ‘remind’ links werken niet

08 sep 2023 12:03 - 08 sep 2023 14:43
#1
Hallo Forum,

Website gemaakt in Joomla 4.3.2

In het login formulier kun je je wachtwoord opnieuw instellen en je gebruikersnaam opvragen.
Beide knoppen werken niet (meer).
Krijg de volgende melding.

0 Call to a member function get() on null
It appears the page you were looking for doesn't exist. Sorry about that.

Ook wanneer ik een nieuw menu-item maak voor 'wachtwoord herstellen' en 'Gebruikersnaam opvragen'

Enig idee hoe ik dit kan herstellen?

Groet, Marcel
Laatst bewerkt 08 sep 2023 14:43 door Astrid.

Inloggen of Een account aanmaken om te kunnen reageren.

  • StudioTh
  • StudioTh's berichtenfoto Heeft onderwerp gestart
  • Nieuw op Joomla!NL
  • Nieuw op Joomla!NL
  • Berichten: 3

Wachtwoord ‘reset’ en gebruikersnaam ‘remind’ links werken niet

08 sep 2023 12:37
#2
Namens het Joomla!NL team heet ik je van harte welkom op dit forum.

Ik ben dit nog nooit tegengekomen. Neem overigens aan dat de site inmiddels geüpdatet is naar 4.3.4?

Kijk even of je iets meer te zien krijgt als je de foutopsporing aanzet en/of de foutrapportage op maximum zet.
Groetjes, Astrid
Gebruik de zoekfunctie van dit forum voordat je een nieuwe vraag plaatst.
Vragen uitsluitend via dit forum.
yndi.nl - kvk 17157725
Is je vraag beantwoord? Dan kan je het draadje zelf sluiten .
Wil je Joomla!NL steunen? Dat kan met een donatie.

Inloggen of Een account aanmaken om te kunnen reageren.

  • Astrid
  • Astrid's Profielfoto
  • Moderator + Technisch team
  • Moderator + Technisch team
  • Berichten: 37084

Wachtwoord ‘reset’ en gebruikersnaam ‘remind’ links werken niet

08 sep 2023 13:42 - 08 sep 2023 14:42
#3
Site is geupdate naar Joomla 4.3.4

Krijg op elke pagina deze melding:

Deprecated: htmlspecialchars(): Passing null to parameter #1 ($string) of type string is deprecated in
/Applications/XAMPP/xamppfiles/htdocs/wij/templates/..../html/layouts/chromes/card.php
on line 25

Line 25: $moduleAttribs = $module->position . ' card ' . htmlspecialchars($params->get('moduleclass_sfx'), ENT_QUOTES, 'UTF-8');



https://.......nl/inloggen?view=remind Geeft volgende melding
Code:
[b][1/2] Error:[/b] Call to a member function get() on null at /home/................/public_html/plugins/captcha/recaptcha/src/Extension/ReCaptcha.php:98 at Joomla\Plugin\Captcha\ReCaptcha\Extension\ReCaptcha->onInit('jform_captcha') at call_user_func_array(array(object(ReCaptcha), 'onInit'), array('jform_captcha')) (/home/................/public_html/libraries/src/Captcha/Captcha.php:215) at Joomla\CMS\Captcha\Captcha->update('onInit', array('id' => 'jform_captcha')) (/home/................/public_html/libraries/src/Captcha/Captcha.php:118) at Joomla\CMS\Captcha\Captcha->initialise('jform_captcha') (/home/................/public_html/libraries/src/Captcha/Captcha.php:143) at Joomla\CMS\Captcha\Captcha->display('jform[captcha]', 'jform_captcha', ' required') (/home/................/public_html/libraries/src/Form/Field/CaptchaField.php:182) at Joomla\CMS\Form\Field\CaptchaField->getInput() (/home/................/public_html/libraries/src/Form/FormField.php:1029) at Joomla\CMS\Form\FormField->renderField(array('class' => '', 'rel' => '', 'hiddenLabel' => false, 'hiddenDescription' => false, 'inlineHelp' => false)) (/home/................/public_html/libraries/src/Form/Form.php:558) at Joomla\CMS\Form\Form->renderFieldset('default') (/home/................/public_html/components/com_users/tmpl/reset/default.php:37) at include('/home/................/public_html/components/com_users/tmpl/reset/default.php') (/home/................/public_html/libraries/src/MVC/View/HtmlView.php:410) at Joomla\CMS\MVC\View\HtmlView->loadTemplate(null) (/home/................/public_html/libraries/src/MVC/View/HtmlView.php:203) at Joomla\CMS\MVC\View\HtmlView->display(null) (/home/................/public_html/components/com_users/src/View/Reset/HtmlView.php:99) at Joomla\Component\Users\Site\View\Reset\HtmlView->display() (/home/................/public_html/components/com_users/src/Controller/DisplayController.php:138) at Joomla\Component\Users\Site\Controller\DisplayController->display() (/home/................/public_html/libraries/src/MVC/Controller/BaseController.php:678) at Joomla\CMS\MVC\Controller\BaseController->execute('display') (/home/................/public_html/libraries/src/Dispatcher/ComponentDispatcher.php:143) at Joomla\CMS\Dispatcher\ComponentDispatcher->dispatch() (/home/................/public_html/libraries/src/Component/ComponentHelper.php:361) at Joomla\CMS\Component\ComponentHelper::renderComponent('com_users') (/home/................/public_html/libraries/src/Application/SiteApplication.php:208) at Joomla\CMS\Application\SiteApplication->dispatch() (/home/................/public_html/libraries/src/Application/SiteApplication.php:249) at Joomla\CMS\Application\SiteApplication->doExecute() (/home/................/public_html/libraries/src/Application/CMSApplication.php:293) at Joomla\CMS\Application\CMSApplication->execute() (/home/................/public_html/includes/app.php:61) at require_once('/home/................/public_html/includes/app.php') (/home/................/public_html/index.php:32)
Code:
[b]2/2 UnknownAssetException[/b] Joomla\CMS\WebAsset\Exception\UnknownAssetException: There is no "template.user" asset of a "style" type in the registry. at /home/................/public_html/libraries/src/WebAsset/WebAssetRegistry.php:134 at Joomla\CMS\WebAsset\WebAssetRegistry->get('style', 'template.user') (/home/................/public_html/libraries/src/WebAsset/WebAssetManager.php:263) at Joomla\CMS\WebAsset\WebAssetManager->useAsset('style', 'template.user') (/home/................/public_html/libraries/src/WebAsset/WebAssetManager.php:197) at Joomla\CMS\WebAsset\WebAssetManager->__call('usestyle', array('template.user')) (/home/................/public_html/templates/wijbegintbijjou/error.php:76) at require('/home/................/public_html/templates/wijbegintbijjou/error.php') (/home/................/public_html/libraries/src/Document/HtmlDocument.php:741) at Joomla\CMS\Document\HtmlDocument->_loadTemplate('/home/................/public_html/templates/wijbegintbijjou', 'error.php') (/home/................/public_html/libraries/src/Document/HtmlDocument.php:796) at Joomla\CMS\Document\HtmlDocument->_fetchTemplate(array('template' => 'wijbegintbijjou', 'directory' => '/home/................/public_html/templates', 'debug' => false, 'csp_nonce' => null, 'templateInherits' => '', 'params' => object(Registry), 'file' => 'error.php')) (/home/................/public_html/libraries/src/Document/HtmlDocument.php:613) at Joomla\CMS\Document\HtmlDocument->parse(array('template' => 'wijbegintbijjou', 'directory' => '/home/................/public_html/templates', 'debug' => false, 'csp_nonce' => null, 'templateInherits' => '', 'params' => object(Registry), 'file' => 'error.php')) (/home/................/public_html/libraries/src/Document/HtmlDocument.php:631) at Joomla\CMS\Document\HtmlDocument->render(false, array('template' => 'wijbegintbijjou', 'directory' => '/home/................/public_html/templates', 'debug' => false, 'csp_nonce' => null, 'templateInherits' => '', 'params' => object(Registry), 'file' => 'error.php'))

Een andere template geeft alleen deze melding.

0 Call to a member function get() on null
It appears the page you were looking for doesn't exist. Sorry about that.

Edit Astrid: Ik heb de meldingen tussen tags geplaatst, volgende keer graag zelf even doen.
Laatst bewerkt 08 sep 2023 14:42 door Astrid.
Gemarkeerd als webneus door: Astrid

Inloggen of Een account aanmaken om te kunnen reageren.

  • StudioTh
  • StudioTh's berichtenfoto Heeft onderwerp gestart
  • Nieuw op Joomla!NL
  • Nieuw op Joomla!NL
  • Berichten: 3

Wachtwoord ‘reset’ en gebruikersnaam ‘remind’ links werken niet

08 sep 2023 14:41
#4
Zegt me helemaal niks. Is het een nieuwe installatie of een upgrade vanuit joomla 3?
Heb je de corebestanden al een keer opnieuw geinstalleerd?
Welke PHP versie gebruik je een heb je al een andere versie geprobeerd?
Overigens deprecated meldingen zijn niet ernstig. Ter info.
Groetjes, Astrid
Gebruik de zoekfunctie van dit forum voordat je een nieuwe vraag plaatst.
Vragen uitsluitend via dit forum.
yndi.nl - kvk 17157725
Is je vraag beantwoord? Dan kan je het draadje zelf sluiten .
Wil je Joomla!NL steunen? Dat kan met een donatie.

Inloggen of Een account aanmaken om te kunnen reageren.

  • Astrid
  • Astrid's Profielfoto
  • Moderator + Technisch team
  • Moderator + Technisch team
  • Berichten: 37084

Wachtwoord ‘reset’ en gebruikersnaam ‘remind’ links werken niet

08 sep 2023 15:38 - 08 sep 2023 16:04
#5
De foutmelding is weg... nadat ik CAPTCHA - reCAPTCHA in de back-end had ingeschakeld.

Ik gebruik deze extensie nergens.
Er is geen contact- of registratie-formulier op de site.
Dus overal uitgezet.

Algemene instellingen > website > Standaard captcha: 'niets geselecteerd'
Gebruikers: opties > Captcha: 'niets geselecteerd'
Systeem > Extensies: Beheren > CAPTCHA - onzichtbare reCAPTCHA: Status Uitgeschakeld
Systeem > Extensies: Beheren > CAPTCHA - reCAPTCHA: Status Uitgeschakeld

In de foutmelding staat die wel vermeld:

captcha/recaptcha/src/Extension/ReCaptcha.php:98


Na het inschakelen van de extensie CAPTCHA - reCAPTCHA is de foutmelding verdwenen......
Alle andere instellingen hetzelfde gehouden.

Om het te testen heb ik de captcha ook weer even uitgezet. Maar nu foutmelding blijft weg.
Beetje vreemd, maar het werkt weer.
Laatst bewerkt 08 sep 2023 16:04 door Astrid.

Inloggen of Een account aanmaken om te kunnen reageren.

  • StudioTh
  • StudioTh's berichtenfoto Heeft onderwerp gestart
  • Nieuw op Joomla!NL
  • Nieuw op Joomla!NL
  • Berichten: 3

Wachtwoord ‘reset’ en gebruikersnaam ‘remind’ links werken niet

08 sep 2023 16:53
#6
Dank voor je update van de situatie.
Is het oké als we dit topic dan sluiten?
Met vriendelijke groet,
Wouter Compactweb.nl
Voordat je een vraag post, gebruik eerst de zoekfunctie van ons forum.
Wil je Joomla!NL steunen? Dat kan met een donatie.

Inloggen of Een account aanmaken om te kunnen reageren.

  • WoodyF4u
  • WoodyF4u's Profielfoto
  • Moderator + Nieuwsteam
  • Moderator + Nieuwsteam
  • Berichten: 11165
Tijd voor maken pagina: 1.212 seconden

Wil je Joomla!NL steunen?

Steun Joomla!NLAlle teamleden werken enthousiast, op vrijwillige basis, mee aan Joomla!NL. Maar een website met forum kost nu eenmaal geld. Dus als je Joomla!NL wilt steunen, dan kan dat, graag zelfs!

Lees hier meer informatie